icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.xhcjdjy.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

中大奖彩票 www.16830.com-海南飞鱼彩票走势图| www.6674.biz-福彩官方电话号码| www.121585.com-手机彩票输了3万| www.e15.pw-网易彩票是真的吗| www.158473.com-重庆时时彩钻石团队| www.62202.com-彩票概率周期| www.703763.com-时时彩手机助手| www.606906.com-福彩票无人彩票机| www.712212.com-彩票坊哪年成立的| www.821946.com-买彩票怎样中五百万| www.922782.com-人人彩票网址| 幸运彩票www.444069.com| www.31ih.com-七乐彩每周开奖几次| www.169604.cc-快三高手怎么看走势| www.518236.com-优乐网上打彩票| www.624456.com-广东福彩开奖查询| www.718212.com-彩票驿站骗人| www.817176.com-968彩票登陆| www.918060.com-900彩票官网| 大玩家彩票www.84499c.com| www.0412.date-助赢彩票软件安卓| www.53765.cc-竞彩店怎么申请退款| www.037079.com-最好的3d彩票软件| www.977570.com-彩票截止时间| www.098348.com-国彩在线-| www.tw29.com-360足彩军长推荐| www.651110.com-水彩颜料创意画| www.783198.com-苏宁彩票大发快三| www.896197.com-中彩票预兆-| 凤凰彩票www.5091v.com| www.279665.com-时时彩公式怎样算| www.9214.love-航空彩虹股-| www.55135.com-浙江省12选5乐彩| www.5638.pw-亿发博彩-| www.885072.com-合肥福彩兑奖中心| www.20it.com-中华彩票正规吗| www.210362.com-快三第一门户app| www.4157.cc-七彩阳光教学视频| www.0782.xyz-yy彩票官方-| www.21707.com-彩票复选是什么意思| 金掌柜www.83993d.com| www.012656.com-廉江好彩哥交流论坛| www.145813.com-中国足彩网官方客服| 七星乐www.535666e.com| www.549788.com-去体彩店怎么买彩票| www.33215.com-全民彩票平台下载| www.11pv.com-时时彩5分钟一期| www.81mf.com-pc时时彩链接| www.69596.com-九九集团快三| www.52773.cc-七彩视界靠谱么| www.wl98.cc-玩彩票一天赚两三千| www.18jp.com-亿彩天虹软件使用| www.852.pw-彩票公鸡图-| www.855430.com-彩先知288元一台| www.006314.com-快三二同号稳赚技巧| www.131737.com-网上彩票怎么代理| www.23787.cc-现在微信能打彩票吗| www.426364.com-新浪胜负彩开奖结果| www.552805.com-彩名堂做假-| www.635495.com-彩70彩票计划| www.757797.com-众彩易购是假的吗| www.845501.com-三四五福彩什么意思| www.825133.com-江苏体彩助手| www.898247.com-广西体彩app| www.969179.com-金山彩票软件正规吗| 亿彩网www.906880.com| www.js96.com-乐彩17500首页| www.9997.bid-567彩票主播| www.944033.com-春秋彩票官-| www.540277.com-96.cc彩票至尊| www.619546.com-彩票筛选器app| www.688361.cc-福彩3d输了-| www.764234.com-彩克下载-| www.843344.com-体彩顶呱刮一等奖| www.917013.com-500彩骗局-| www.974017.com-众彩网双色球筱彬| 天下彩www.741770.com| www.197872.com-彩票开奖走势图大全| www.9998.bid-福彩3d数字阵| www.57114.com-泊松足彩模型下载| www.670645.com-內蒙福彩-| www.009348.com-178彩票下载| www.119994.com-广西一定牛快三| www.252548.com-彩票作假事件| www.370127.com-28cc天下彩| www.us88.cc-快彩官方网邀请码| www.78wu.com-彩迷张双色球| www.ya04.com-美高梅韩国快三| www.400.host-境外博彩客服犯法吗| www.69625.com-九九集团彩票官网| www.036191.com-彩票统计安全下载| www.195699.com-全部彩种-| www.261833.com-最安全的彩票网站| www.01708.com-天天中彩票提款多久| www.496801.com-六爻测3d彩票方法| www.597263.com-众亿彩下载-| www.eb67.com-百姓网彩票-| www.661343.com-体彩三十一选七规则| www.789582.com-竞彩亚盘干货| www.920862.com-优乐彩票下载安装| www.w94.net-中国彩票计划| www.211710.com-国家手机购彩软件| www.85mw.com-陕福利彩票开奖结果| www.88417.cc-奥地利彩票中最大奖| www.577814.com-酷彩吧可信吗| www.652398.com-体彩什么时间开奖| www.986075.com-彩票出票员-| www.at08.com-精彩十分玩法图| www.sg75.com-时时彩规律研究| www.19fu.com-买彩票犯法不| www.fy83.com-三分时时彩开奖| www.346345.com-abc彩票登录| www.070286.com-彩亿计划-| www.822330.com-彩票怎么选数| www.905414.com-足彩任九技巧| www.959738.com-彩61主页-| 福利彩票www.8039m.com| www.599557.com-篮球体彩网-| www.865765.com-彩票921-| www.274621.com-你们玩快三玩什么| www.420808.com-大乐彩网站-| www.658225.com-彩送-| www.426670.com-烟台体彩管理中心| www.902613.com-黑彩代理能赚多少钱| www.994194.com-快彩电子走势图电视| www.pa11.com-快三秒盗窃| www.51838.cc-下载牛蛙彩票| www.378049.com-肥乡抵制彩礼| www.783508.com-彩78彩票官方网站| www.853499.com-365竞彩app-| www.588198.com-波彩之家网络| www.1950.cc-福彩3d怪字怪帖| www.089056.com-重庆市彩票-| www.10dy.com-天霁彩票网手机版| www.3130.biz-广西快三淘宝| www.00196.com-彩钢板临时围挡| www.739601.com-中华福彩开机号| www.841055.com-彩票主任判死刑| www.905810.com-祥云瑞彩图片| www.973635.com-快三能回本吗| www.412439.com-绵阳彩钢围挡定做| www.101424.com-500足彩胜负| www.611289.com-吉祥8彩票是真的吗| www.759151.com-万彩吧彩票高手| www.857366.com-快彩被骗-| www.936066.com-黑科技博彩漏洞赚钱| www.990973.com-福彩揭秘-| www.bl07.com-分分快三彩票| www.322299.com-137彩票平台下载| www.488004.com-网易彩票资汛| www.556772.com-澳门彩报图3d| www.616360.com-亚彩会游戏官网| www.671407.com-彩乐园1邀请码| www.722725.com-每日存款彩票平台| www.776007.com-时时彩较稳的玩法| www.831690.com-26选5好彩三结果| www.882233.cc-体彩直选3开奖结果| www.929531.com-七乐彩胆拖选号器| www.971507.com-中国福体彩-| 500彩票www.50051m.com| www.19309.cc-福彩3d天牛网| www.644491.com-腾讯分分彩走势图| www.998164.com-海口七星彩开心网| www.562205.com-福彩300秒-|